Instalar o draftSight no ElementaryOS Luna 64bits

draftSight on elementaryOS Luna 64bits

Instalar o synaptic:

sudo apt-get update

sudo apt-get install synaptic

Executar o synaptic e abrir “Configurações > Repositorios”

Clicar em “Outros softwares > Adicionar”

Inserir esta linha na caixa de dialogo “deb http://archive.ubuntu.com/ubuntu/ raring main restricted universe multiverse

Clicar ok e fechar o synaptic

depois:
sudo apt-get update

É só update: Não fazer upgrade até estar o draftSight instalado: apenas queremos instalar uma biblioteca em particular, não queremos actualizar o sistema todo!

sudo apt-get install ia32-libs

Aqui deu-me um erro a instalar o gvfs-backends, Se der o mesmo erro:
sudo apt-get install gvfs-backends

Em seguida:
sudo apt-get install libdirectfb-extra libxcb-render-util0

O passo seguinte pode dar erro a dizer que faltam as bibliotecas xdg_utils, mas não há problema:
sudo dpkg -i draftSight.deb

Este passo instala o xdg_utils e completa a instalação do draftSight:
sudo apt-get -f install

Por fim, abrir o synaptic e remover o repositório que acrescentámos, senão o próximo upgrade vai causar problemas no sistema.

Instalar drivers da Ati

Ao gerar os pacotes para o ubuntu os drivers da Ati falham com o erro:

Package build failed!
Package build utility output:
./packages/Ubuntu/ati-packager.sh: 294: ./packages/Ubuntu/ati-packager.sh: debclean: not found
./packages/Ubuntu/ati-packager.sh: 295: ./packages/Ubuntu/ati-packager.sh: dpkg-buildpackage: not found
[Error] Generate Package - error generating package : Ubuntu/raring

Resolução:
Instalar devscripts:
sudo apt-get install build-essential cdbs fakeroot dh-make debhelper debconf libstdc++6 dkms libqtgui4 wget execstack libelfg0 dh-modaliases linux-headers-generic lib32gcc1 libc6-i386

e ia32-libs
sudo apt-get install ia32-libs

Linux: “libc6 was found in an unexpected directory”

Após uma tentativa falhada para instalar o Steam beta o apt-get começou a falhar com o erro:

[root@server][~] $ apt-get upgrade
 Reading package lists... Done
 Building dependency tree
 Reading state information... Done
 You might want to run 'apt-get -f install' to correct these.
 The following packages have unmet dependencies:
  libc6 : Depends: libc-bin (= 2.13-20ubuntu2) but 2.13-20ubuntu3 is installed
  libc6-dev : Depends: libc6 (= 2.13-20ubuntu3) but 2.13-20ubuntu2 is installed
 E: Unmet dependencies. Try using -f.

Continuar a ler “Linux: “libc6 was found in an unexpected directory””